Wie beheben Sie die Fehlermeldung 'NgRfc Header Flag missing'?
Ursache
Diese Meldung erscheint, wenn RFC-Bibliotheken (DLL) verwendet werden, die älter als vom 3. Dezember 2025 sind. Der Grund hierfür ist, dass SAP in diesen älteren DLLs einen Fehler hatte, der diese Fehlermeldung verursachte.
Lösung
Um dieses Problem zu beheben, müssen Sie die DLLs auf neuere Versionen aktualisieren.
Falls Sie keinen Zugriff auf das SAP Software Center haben, um die neuen DLLs selbst herunterzuladen, kontaktieren Sie bitte unser Support Team (support@dab-gmbh.de).
Folgen Sie diesen Schritten, um die DLLs zu aktualisieren:
- Gehen Sie zum SAP Software Center
- Suchen Sie nach SAP NW RFC SDK 7.50
- Sie können im Download-Menü das Betriebssystem und die Architektur ändern
- Das Download-Archiv ist eine normale ZIP-Datei, die mit Standard-Tools geöffnet werden kann
- Wechseln Sie in den lib-Ordner innerhalb der ZIP-Datei
- Sie benötigen die folgenden DLLs (das XX steht für die Releasenummer und kann variieren):
- icudtXX.dll
- icuinXX.dll
- icuucXX.dll
- libsapucum.dll
- sapnwrfc.dll
- Stoppen Sie den dab Nexus-Dienst
- Kopieren Sie die Dateien an den richtigen Speicherort (64-Bit-Bibliotheken): %WINDIR%\System32
Wenn Sie gefragt werden, ob Sie eine vorhandene icudtXX.dll, icuinXX.dll oder icuucXX.dll überschreiben möchten, klicken Sie auf Nein! Das Überschreiben dieser Dateien kann dazu führen, dass andere Anwendungen nicht mehr korrekt funktionieren.
Die Datei sapnwrfc.dll muss überschrieben werden.
- Starten Sie den dab Nexus-Dienst nach dem Ändern der DLLs neu!
- Passen Sie die SAP-Verbindung in dab Nexus an:
- Für ältere dab Nexus-Versionen: Entfernen Sie die Auswahl der Option 'Is S/4HANA'
- Für neuere dab Nexus-Versionen: Wechseln Sie von S/4HANA auf ECC
- Legen Sie eine neue Aufgabe an (oder duplizieren Sie eine bestehende)
- Überprüfen Sie die Protokolle, falls der Lauf fehlschlägt -> bleibt der Fehler bestehen, wenden Sie sich bitte an unser Support Team und senden Sie das vollständige Support-Paket an support@dab-gmbh.de